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Installation de la version d'évaluation de P-CAD 2001

Démarrage de P-CAD 2001

Pour démarrer P-CAD 2001, sélectionnez l'icône correspondante dans le dossier
Programs » P-CAD 2001 Trial Version du menu Démarrer de Windows.

Ce manuel vous décrit quelques-unes des principales fonctions et
fonctionnalités proposées. Cependant, il ne constitue nullement une
présentation complète des possibilités offertes par P-CAD 2001. Pour de plus
amples informations ou pour obtenir des renseignements techniques, veuillez
visiter www.pcad.com.

Remarque concernant la version d'évaluation
Ce CD d'évaluation contient une version complète et opérationnelle de P-CAD
2001, que vous pourrez utiliser pendant une période strictement limitée à 30
jours à compter de votre première utilisation. Vous ne pourrez pas prolonger
la durée de cette période d'essai, même en tentant de réinstaller le logiciel. 

Avertissement : cette version d'évaluation de P-CAD 2001 ne peut être installée qu'une
seule fois sur un ordinateur donné. Si vous tentez de prolonger la période d'essai en modifiant
l'horloge système, en réinstallant le logiciel ou en le déplaçant vers un autre répertoire, le
programme deviendra inutilisable. En cas de problème à l'installation, ne désinstallez pas le
logiciel, mais réinstallez-le dans le même répertoire.

Remarque à l'intention des personnes utilisant déjà P-CAD
Le fait d'installer la version d'évaluation de P-CAD 2001 est sans incidence
sur vos installations existantes de P-CAD. La version d'évaluation de P-CAD
2001 peut fonctionner en même temps que d'autres versions de P-CAD, 
y compris P-CAD 2000.

1. Introduisez le CD d'évaluation de P-CAD 2001 dans votre lecteur de CD ROM.
Sur la plupart des systèmes, le programme d'installation démarre
automatiquement lorsque vous refermez le plateau du lecteur.

2. Si la fenêtre du programme d'installation ne s'affiche pas automatiquement,
lancez le programme Setup.exe qui se trouve dans le répertoire P-CAD 2001
du CD d'installation.

Dès que démarre ce programme d'installation, un Assistant vous guide à travers la
procédure d'installation. Remarque : si vous installez P-CAD2001 sous Windows NT, vous
devez disposer des privilèges d'administrateur local pour réussir votre installation.

Configuration requise :
Configuration recommandée :

- Windows NT 4/2000 Professional

- PC équipé d'un processeur Pentium III

- 128Mo de BRAM (256Mo pour les grandes 
densités de composants/équipotentielles)

- 400 Mo d'espace disque dur

- Affichage 1024x768 pixels

- Palette couleurs 32 bits

- Lecteur de CD-ROM

- Souris ou dispositif de pointage compatible

Configuration minimale :

- Windows 95/98/2000Me

- PC équipé d'un Pentium 166 MHz

- 64 Mo de RAM

- 200Mo d'espace disque dur

(sans les bibliothèques ISO)

- Affichage 800x600 pixels

- Palette 256 couleurs

A propos de ce manuel
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1. Barre d'outils des commandes. Contient une combinaison de fonctions
standard Windows et de fonctions spécifiques P-CAD 2001.

2. Barre d'outils de routage interactif. Durant la phase de routage de votre
circuit imprimé, cette barre d'outils vous permet d'utiliser des techniques de
routage interactif telles que le fan-out, l'écartement des traces, le routage de
bus et le routage multi-fils.

3. Barre d'outils de documentation. Contient des raccourcis vers les fonctions
utilisées pour la création de la documentation des fichiers du projet. S'utilise
dans l'Editeur de circuits imprimés et dans l'Editeur de schémas.

4. Barre d'outils de placement. Met en œuvre le placement des entités du
projet telles que les composants, les connexions, les fils et les bus.

5. Ligne d'invite. Barre d'outils dynamique qui vous indique la prochaine action
à effectuer.

6. Ligne d'état. Vous informe de l'état de votre projet.
a. Coordonnées. Vous indiquer les coordonnées de votre projet. Utilisez la touche "J" 

pour activer la boîte de saisie des coordonnées. Utilisez la touche TAB pour basculer 
entre coordonnées en X et coordonnées en Y.

b. Paramétrage de la grille. Indique le paramétrage de la grille en cours. Permet 
également de basculer entre paramètres absolus et relatifs de la grille.

c. Grilles. Indique l'état de la grille en cours. Permet d'ajouter des grilles "à la volée" en 
saisissant un nouvel espacement de grille à partir de la ligne d'état. Convertit 
automatiquement l'espacement de grille saisi dans l'unité d'espace de travail définie.

d. Enregistrement de macro. Appuyez pour enregistrer ou cesser d'enregistrer 
une macro.

e. Boîte de dialogue couche/page. Appuyez pour activer la boîte de dialogue de la couche
ou de la page sélectionnée.

f. Sélection de couche/page. Appuyez pour passer d'une couche ou d'une page 
à la suivante.

g. Largeur de ligne. Appuyez pour sélectionner une valeur dans la liste des largeurs de 
ligne disponibles.

h. Boîte de sélection de rayon. Sous l'Editeur de circuits imprimés et l'Editeur de modèles, 
affiche le rayon utilisé pour le placement des formes polygonales dotées de coins 
arrondis. Vous pouvez sélectionner un rayon dans la liste déroulante ou en saisir 
un nouveau.

Présentation de P-CAD 2001

a         b     c      d             e  f    g           h
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Pour utiliser la fonction d'aide en ligne de P-CAD 2001, il vous suffit de
sélectionner l'option Help de la Barre de menus ou d'appuyer sur F1 en n'importe
quel point de l'écran. Vous êtes alors connecté au système d'aide de Windows, qui
vous donne des instructions quant à l'utilisation du système. P-CAD 2001 comporte
également une Info-bulle qui vous indique comment définir des icônes dans
l'interface. Pour savoir à quoi sert une icône donnée, il vous suffit de placer le
curseur dessus : un cadre contenant de l'information s'affiche alors.

F1 Aide
MAJ+F4 Mosaïque
MAJ + souris Sous-sélection
Suppr Suppression de 

l'objet sélectionné
Echap Annulation de souris
PgPréc Page précédente
PgSuiv Page suivante
Ctrl+souris Sélection multiple
Ctrl+PgPréc Défilement vers la gauche
Ctrl+PgSuiv Défilement vers la droite
(+) ou (=) Zoom avant
(-) Zoom arrière
Touches fléchées Déplacement du curseur 

d'un point de grille

A Basculement de grille
C Zoom centre
F Retourner les 

objets/basculer en mode 
orthogonal

G Parcours à travers 
les grilles

J Saisie de coordonnée
M Démarrage ou arrêt de 

l'enregistreur de macros
O Parcours à travers les 

modes orthogonaux
R Rotation des objets de 90°
S Edition de la sélection
U Annulation
Z Zoom de fenêtre

Obtenir de l'aide Altium Total Support pour P-CAD 2001
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Raccourcis utiles
Les raccourcis ci-dessous sont configurés par défaut sous P-CAD 2001. Vous
pouvez les modifier en sélectionnant Options » Préférences dans la barre
d'outils des commandes.

Chez Altium, notre philosophie
consiste à aider chaque
ingénieur, concepteur ou
développeur à transformer ses
idées en produits et
applications de qualité, de la
manière la plus simple et la
plus productive possible.

C'est ce qui nous a incités à
mettre au point le programme
Altium Total Support (ATS)

Ce tout nouveau système de
support technique succède à P-
CAD Total Support et vous
permet de rester à tout
moment à la pointe de la CAO
électronique, en recevant les
dernières versions de produits,
les service packs, les
compléments et les
technologies offertes en prime,
que nous vous envoyons à
mesure de leur parution. Votre
adhésion au programme ATS
vous évite l'inconfort et les
complications liées aux vastes
mises à niveau, tout en vous
permettant de disposer d'un
support technique ouvert 24
heures sur 24, 7 jours sur 7, de
recevoir les nouvelles
bibliothèques et les mises à
jour, les astuces techniques,
ainsi que les offres spéciales
réservées à nos adhérents.

L'adhésion au programme ATS
vous permettra de rester à la
pointe de la technologie de la
manière la plus économique
qui soit. Les adhérents au
programme ATS bénéficiant
également d'un accès exclusif à
nos offres spéciales sur
l'ensemble de notre gamme de
logiciels de conception, vous
pourrez élargir les possibilités
de votre kit d'outils aux tarifs
les plus compétitifs qui soient.

Avec ATS, vous n'aurez que des
avantages. En tant
qu'utilisateur des logiciels
Altium, vous avez investi dans
les meilleurs outils de CAO du
marché. Avec ATS, vous aurez
accès à une immense
expérience cumulée et à un
savoir de pointe. Vous serez
ainsi assuré de tirer le meilleur
parti de votre investissement.
L'adhésion au programme ATS
est renouvelable annuellement.
Pour savoir ce que peut vous
apporter ATS, contactez votre
centre local Altium.

Restez à la pointe de la CAO
électronique

Accédez rapidement et
facilement à un support
technique de haut niveau

Minimisez les besoins de
formation de votre équipe de
concepteurs

Optimisez les performances de
vos outils de conception

Eliminez le besoin d'un
lobbying permanent pour vos
mises à niveau logicielles

Le résultat final, qui correspond
exactement à l'objectif d'ATS,
est de vous aider à écourter vos
délais de mise sur le marché,
tout en vous permettant
d'optimiser votre niveau de
qualité. En d'autre termes :
vous permettre d'emprunter la
meilleure voie vers la réussite.
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Saisie et gestion de projet

Comment configure-t-on un nouveau projet de schémas de P-CAD 2001 ?
1. Sélectionnez l'icône Schematic dans le dossier Programs » P-CAD 2001 Trial

Version du menu Démarrer de Windows.

2. Sélectionnez l'option File » New.

3. Sélectionnez Options » Configure pour définir l'environnement de saisie de
votre projet. Choisissez l'une des tailles prédéfinies d'espace de travail ou

définissez une nouvelle taille en sélectionnant le
bouton User et en saisissant une largeur et une
hauteur personnalisées. Cliquez sur le bouton Edit
Title Sheets pour définir et afficher le périmètre des
bordures, les zones horizontale et verticale et les blocs
de titre personnalisés et prédéfinis. Quittez la boîte de
dialogue Edit Title Sheets pour retourner à Options
» Configure et définir les modes orthogonaux
souhaités pour le placement des fils, des bus et des
lignes. Définissez l'Incrément des équipotentielles, qui
doit servir à incrémenter les noms des équipotentielles
lors de l'utilisation des fonctions de copie. Choisissez
le format Engineering Change Order pour
enregistrer vos modifications dans le projet en cours -

sélectionnez le format ECO lorsque vous devez enregistrer des ajouts,
suppressions ou modifications de pièces, d'équipotentielles, de nœuds ou
d'attributs. Sélectionnez le format Was/Is pour uniquement garder trace des
modifications apportées à RefDes. Utilisez les commandes du cadre
AutoSave pour activer la fonction AutoSave, qui enregistre vos fichiers à
intervalles prédéfinis par vous, au format comprimé ou non comprimé. Utilisez
le cadre Units pour changer d'unité d'affichage (mils, millimètres ou pouces).
Dans l'Afficheur de fichiers, définissez l'afficheur à utiliser pour visualiser les
comptes-rendus, fichiers journaux, comptes-rendus d'erreurs, etc.

Saisissez le nom du programme (Bloc-Notes, par exemple). Si ce programme 
réside dans un répertoire qui ne figure pas dans la commande de chemin de 
votre système, vous devez ajouter le chemin complet ici. Saisissez une valeur 
de Zoom Factor pour régler le zoom à effectuer lorsque vous sélectionnez 
l'option View » Zoom In (+) ou View » Zoom Out (-). Le cadre Autopan
vous permet de régler le niveau d'autopanning à effectuer lorsque vous 
déplacez le curseur vers le bord de l'écran à l'aide des 
touches fléchées. Activez les DDE Hotlinks pour 
échanger des données de hotlink avec votre projet 
de circuit imprimé. Sélectionnez la case à cocher 
Compress Binary Designs pour activer la 
compression automatique des fichiers binaires 
lors de leur sauvegarde.

4. Une fois que vous avez configuré votre 
environnement de projet, refermez la boîte de 
dialogue en sélectionnant OK. Choisissez Options » 
Grids dans la Barre d'outils de commande pour configurer l'espacement des 
grilles à utiliser dans le cadre de la saisie de votre projet de circuit imprimé. 
Tapez un paramètre de grille dans le cadre Grid Spacing et sélectionnez le 
bouton Add. Saisissez autant de grilles que vous le souhaitez. Choisissez un 
style de grille visible ou désactivez-le totalement. Sélectionnez un Mode pour 
employer une origine de grille Absolute ou Relative. Si vous choisissez une 
grille Relative, saisissez les coordonnées d'origine souhaitées dans le cadre 
Relative Grid Origin ou sélectionnez Prompt for Origin pour entrer dans 
l'environnement du projet et cliquer sur le point d'origine de votre choix. 
Sélectionnez OK pour quitter la boîte de dialogue Options » Grids et 
enregistrer vos paramètres.

5. Sélectionnez Options » Sheets pour définir le nombre et l'ordre des pages de 
schéma à utiliser dans votre projet. Pour créer un schéma multi-pages, saisissez 
le nom de la page supplémentaire dans le cadre Sheet Name.
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Sélectionnez le bouton Add pour activer la page
dans votre projet. Vous pouvez ajouter jusqu'à 999
pages à un projet de schéma. Utilisez les boutons
Move Up et Move Down pour réorganiser vos
pages dans le projet. Une fois que vous avez
configuré le nombre de pages souhaitées,
sélectionnez le bouton Close pour retourner à
l'environnement de saisie de projet et commencer
à placer les objets de votre projet de schéma.

Comment contrôle-t-on l'intégrité
électrique des schémas 
1. Ouvrez le fichier Digdemo.sch, qui réside dans 

le dossier \P-CAD 2001 Trial\Demo\.

2. L'Editeur de schémas de P-CAD 2001 comporte 
des fonctions de contrôle des règles électriques 
qui permettent de vérifier le tracé et l'intégrité 
électrique de votre projet en phase de saisie.

Sélectionnez Utils » ERC. La boîte de
dialogue Electrical Rules Check
s'affiche en indiquant les règles de tracé
et d'intégrité électrique à vérifier,
diverses options de reporting, la
possibilité d'activer les indicateurs visuels
de violation, ainsi qu'une boîte de
dialogue de niveau de gravité qui classe
vos règles électriques par catégories en
fonction de la gravité et du type.

3. Dans le cadre Design Rule Checks, activez tous les contrôles, à l'exception
des Hierarchy Rules. Les options sélectionnées dans cette boîte de dialogue
déterminent quelles erreurs doivent figurer dans le compte-rendu.
Sélectionnez le bouton Filename pour modifier le nom du compte-rendu si
vous le souhaitez.

4. Sélectionnez le bouton Severity Levels
pour appliquer à chacune des règles un
niveau de gravité de type Error, Warning
ou Ignored.

5. Cliquez sur l'en-tête Catégorie de règle
pour trier vos règles de conception par
catégorie.

6. Multi-sélectionnez les Règles électriques
Bi Pin To Power Pin et Power Pin to Bi
Pin et choisissez le bouton radio Severity
Level, Warning. Les violations de cette catégorie seront désormais
marquées comme étant des avertissements et non pas des erreurs.

7. Vous pouvez annuler vos modifications et revenir à vos paramètres initiaux
en cliquant sur la case à cocher Set to default. Cliquez ensuite sur OK pour
revenir à la boîte de dialogue Utils ERC.

8. Activez l'option View Report pour afficher à l'écran le fichier du compte-
rendu d'ERC une fois les contrôles effectués. Activez l'option Summarize
Ignored Errors pour faire apparaître le résumé des erreurs dont le niveau
de gravité a été initialisé à Ignored.

9. Sélectionnez l'option Annotate Errors pour afficher les indicateurs d'erreur
d'ERC de votre projet là où sont intervenues des violations.

10.Cliquez sur OK pour lancer l'ERC. Le compte-rendu d'ERC Digdemo.erc est
créé et affiché automatiquement.
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Avec son jeu complet de règles électriques, le classement des erreurs par niveau
de gravité et par type, ainsi que la gestion évoluée des erreurs, P-CAD 2001
vous aidera à préserver l'intégrité de vos projets du début jusqu'à la fin.

Comment crée-t-on une BOM pour un projet ?

1. Ouvrez le fichier Modfax0.sch, qui réside dans le 
dossier \P-CAD 2001 Trial\Demo\ folder.

2. Sélectionnez l'option File » Reports. Sélectionnez 
l'option Bill of Materials du cadre Report
to Generate.

3. Sélectionnez l'option Filename pour modifier le 
nom et l'emplacement du compte-rendu à produire. 
Par défaut, ce fichier porte le même nom que le 
projet en cours et réside dans le répertoire des 
comptes-rendus sauvegardés.

4. Sélectionnez la Report Destination. Vous pouvez 
l'envoyer à l'Ecran pour le visualiser sous l'afficheur,
vers un Fichier ou vers une Imprimante.

5. Choisissez le format de sortie. Vous avez le choix 
entre Separated List et P-CAD Report. Si vous 
choisissez Separated List, sélectionnez le caractère 
destiné à servir de séparateur de liste.

6. Sélectionnez Customize pour créer un compte-
rendu personnalisé. Vous pourrez le formater, définir
des champs spécialisés, un ordre de tri spécifique, 
voire une extension de fichier personnalisée.

7. Sélectionnez l'option Generate pour créer votre 
compte-rendu BOM tel que vous l'avez configuré.

11. Le compte-rendu d'ERC indique différents
types d'erreurs et d'avertissement
concernant les violations de Règles
électriques et de Broches non 
connectées. Ils correspondent aux 
conditions configurées dans Severity 
Level et dépendent du type électrique 
des broches de vos composants. 
Sélectionnez l'option File » Exit de 
l'éditeur de texte en cours pour 
refermer le compte-rendu d'ERC et 
retourner au projet de schéma.

12. Etant donné que vous avez sélectionné l'option Annotate
Errors, des indicateurs d'erreur sont placés dans le projet 
pour chaque violation d'une règle dont le niveau de 
gravité a été initialisé à Error. Pour afficher les 
informations d'erreur relatives à un objet donné, entrez 
dans le projet, sélectionnez manuellement un indicateur 
d'erreur et accédez à ses propriétés, ou sélectionnez Utils 
» Find Errors pour activer l'outil de navigation de 
recherche d'erreurs.

13. La boîte de dialogue Find Errors permet de naviguer 
facilement vers les zones problématiques de votre 
schéma, quelle que soit la page contenant une erreur.
Pour utiliser cette boîte de dialogue, parcourez les
numéros d'erreur en notant la violation, l'emplacement 
de la page et les coordonnées de l'objet concerné. Si vous
avez besoin d'analyser une violation de plus près, 

sélectionnez le bouton Jump To de la boîte de dialogue pour positionner votre
curseur à l'emplacement exact de l'erreur dans votre projet.
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Comment génère-t-on une
netlist ?
1. Ouvrez le fichier Digdemo.sch,

qui réside dans le dossier \P-CAD
2001 Trial\Demo\.

2. Choisissez l'option Utils » Generate Netlist. Dans la boîte de dialogue Utils
Generate Netlist, choisissez un nom de fichier de netlist en sélectionnant le
bouton Netlist Filename. La boîte de dialogue Netlist File s'affiche. Elle a le
format standard des boîtes de dialogue d'ouverture de fichier Windows.

3. Dans la boîte de sélection, sélectionnez le format de la netlist à générer :

- P-CAD ASCII - Tango - FutureNet Netlist - FutureNet Pinlist

- Master Designer - EDIF v.2.0.0 - Pspice - Xspice

4. Sélectionnez la case à cocher Include Library Information si vous voulez
qu'une section facultative de bibliothèque soit écrite dans la netlist. 
Lorsque vous chargez une netlist dans l'éditeur de circuits imprimés, les
informations de bibliothèque sont lues sans  traitées, car elles ont un but
purement informatif. Néanmoins, vous pouvez utiliser cette section de
bibliothèque pour créer un fichier de bibliothèque P-CAD à l'aide de la
commande de conversion de bibliothèque.

5. Cliquez sur OK dans la boîte de dialogue Netlist Generate pour générer 
la netlist correspondant au nom de fichier et au format que vous venez 
de spécifier.

Comment génère-t-on une table de broches et
de composants d'alimentation ?
1. Ouvrez le fichier Digdemo.sch, qui réside dans le

dossier \P-CAD 2001 Trial\Demo\.

2. Créez une troisième page de schéma en entrant dans
Options » Sheets, en tapant Sheet 3 dans le champ
Sheet Name, puis en sélectionnant le bouton Add.
Mettez Sheet 3 en surbrillance et choisissez Current
pour en faire la page courante dans l'espace de travail.
Sélectionnez Close pour sauvegarder vos modifications.

3. L'éditeur de schémas doit à présent afficher la Page 3.
Sélectionnez DocTool » Place Table et cliquez une fois 
dans l'espace de travail pour ouvrir la boîte de dialogue 
Place Table.

4. Sélectionnez Power Table dans la liste Table Type, puis
saisissez le nom qui doit s'afficher en haut de la table que
vous aurez placée. Sélectionnez un style de texte et une
largeur de ligne pour la table. Choisissez All Pins dans le
champ Pins to Include et All Components dans le champ
Components to Include. Sélectionnez OK pour confirmer les sélections que
vous avez faites dans la boîte de dialogue et quitter pour placer la table.

5. Cliquez une fois en bas à gauche de la page pour placer le Power Table. 
La table d'alimentation est l'une des nombreuses tables que vous pouvez placer
dans le schéma pour améliorer la gestion de votre projet. La table d'alimentation
indique le désignateur de référence, le type de composant, le modèle de
composant et les équipotentielles de terre des broches d'alimentation du
composant. Les données contenues dans une table de schéma peuvent être
mises à jour automatiquement à l'aide des fonctions de mise à jour que vous
trouverez dans le menu DocTool.
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Comment procède-t-on pour commencer à tracer un circuit ?
1. Sélectionnez l'icône PCB dans le dossier Program » P-CAD 2001 Trial Version du

menu Démarrer de Windows.

2. Sélectionnez File » New.

3. Sélectionnez Options » Configure, onglet General pour définir votre environnement
de tracé. Activez les unités et la taille d'espace de travail de votre choix. La taille de
l'espace de travail a été automatiquement initialisée à 11 000 par 8 500 mils pour
correspondre à une feuille de papier au format 11"x 8.5". Sélectionnez OK pour
retourner à votre espace de travail.

4. Créez le contour de votre carte. Ce contour est généralement placé sur la couche sans
signal, appelée Board. Sélectionnez Options » Layers et initialisez Current Layer
à Board en choisissant cette option dans la liste déroulante. Sélectionnez le bouton
Close. Vérifiez dans le paramètre Status Line » Layer que Board apparaît en tant
que couche en cours.

5. Choisissez Place » Line et cliquez dans l'espace de travail pour définir la forme du
contour de votre circuit imprimé. Pour vous aider, chargez le fichier Demo1_o.pcb à
partir du dossier \P-CAD 2001 Trial\Demo\.

6. P-CAD 2001 vous permet de concevoir des circuits imprimés "à la volée" en plaçant des
modèles et des connexion. Néanmoins, la meilleure méthode consiste à transférer les
données du projet par l'intermédiaire d'une netlist que vous aurez créée à partir de
l'éditeur de schémas. La netlist permet de transmettre toutes les contraintes de conception,
les attributs, les composants et les connexions depuis le circuit vers le tracé de la carte.
Avant de pouvoir commencer à utiliser une méthode de tracé, vous devez commencer
par ouvrir les bibliothèques qui contiennent les composants que vous allez utiliser. Pour
définir une bibliothèque de composants à utiliser sous l'éditeur de circuits imprimés,
sélectionnez Library » Setup. Dans la boîte de dialogue Library Setup, choisissez
l'option Add. Sélectionnez le fichier Demo.lib dans le dossier \P-CAD 2000 Trial\Demo\. 

Cliquez sur OK pour sauvegarder vos modifications et retourner à l'espace de travail.

7. Une fois que vous avez défini vos
bibliothèques, sélectionnez Utils » Load
Netlist pour charger la netlist générée à
partir du projet de schéma. Choisissez le
fichier Demo1.net dans le dossier \P-CAD
2001 Trial\Demo\. Une fois que vous aurez
sélectionné la netlist, le format sera
automatiquement configuré comme étant
de l'ASCII P-CAD. Sélectionnez Optimize
Nets pour optimiser automatiquement les
connexions de la netlist. Sélectionnez OK
pour charger la netlist.

Les bibliothèques adéquates étant ouvertes,
les composants qui figurent dans la netlist
sont automatiquement placés dans l'espace
de travail. Vous pouvez à présent mettre vos
composants en place sur la carte. Vous
remarquerez que les connexions électriques
reprises dans la netlist apparaissent dans le
circuit imprimé, formant un rats nest. La
commande d'édition des équipotentielles
vous permet de désactiver l'affichage des
équipotentielles de votre choix, de manière à
minimiser votre distraction.

Comment organise-t-on et planifie-t-on un circuit une fois que l'on 
a chargé la netlist ?
1. Sous l'éditeur de circuits imprimés de P-CAD 2001, ouvrez le fichier IPLPCS

Design by rules.pcb, qui réside dans le dossier \P-CAD 2001 Trial\Demo\.

Placement précis et édition de circuits imprimés
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4. A partir de l'affichage du Gestionnaire de
projet situé à droite, naviguez à travers les
définitions de Composants, d'Equipotentielles,
de Partitions, d'Emplacements, de Classes
d'équipotentielles et Classe à classe figurant
dans le projet en cliquant sur les onglets
figurant en bas.

5. Sélectionnez l'onglet Room. Cliquez sur le
signe + situé en regard de Top dans
l'arborescence de navigation pour développer
le dossier et afficher l'emplacement appelé
Power. Cliquez sur le signe + situé en regard de Power
pour afficher les composants à placer à l'intérieur des
limites de cet emplacement.

6. Cliquez sur Power pour le mettre en surbrillance sous le
Gestionnaire de projet. Une fois que vous l'avez fait,
cliquez avec le bouton droit de la souris. Sélectionnez les options Highlight
Room et Assigned Components. Les composants mis en surbrillance sont
ceux qui sont attribués à la frontière de l'emplacement en surbrillance, qui
limite le placement des composants à la couche Top.

7. Tout en maintenant Power en surbrillance, cliquez avec le bouton droit de la
souris et sélectionnez Cluster by » Type. Les composants attribués à
l'emplacement Power s'affichent dans la couleur de sélection et
sont bornés par une zone de sélection. Le curseur passe de
l'affichage du Gestionnaire de projet vers l'Affichage de carte et
prend la forme d'un "X", ou curseur de placement.

8. Une fois que vous êtes dans l'espace de l'Affichage de carte,
cliquez avec le bouton gauche de la souris pour regrouper les
composants selon le type de critère spécifié.

2. Dans le menu Utils, choisissez P-CAD InterPlace\PCS pour lancer les outils de
placement interactif de P-CAD.

3. Choisissez File » Load PCB Design. Développez votre espace de
travail de manière à visualiser la carte, le gestionnaire de projet et
l'Editeur de contraintes.

Les outils de placement interactif de P-CAD 2001 vous permettent de
naviguer et d'organiser votre projet de différentes
manières. Dans l'affichage de carte, vous pouvez
visualiser le tracé de la carte, ses trous de
montage, ses connexions et ses composants sous
différents angles, notamment Top Only, Bottom
Only, Top Current et Bottom Current. Sous le
Gestionnaire de projet, vous pouvez organiser et
manipuler les objets du projet par composants,
par équipotentielles, par partitions logiques, par
emplacements, par classes d'équipotentielles et
par définitions classe à classe. Sous l'éditeur de
contraintes, vous pouvez contrôler ou affecter les

règles hiérarchiques configurées dans votre environnement de projet.

Comment procède-t-on pour sélectionner et déplacer un groupe de
composants affectés à un emplacement défini ?
1. Sous l'éditeur de circuits imprimés de P-CAD 2001, ouvrez le fichier IPLPCS Design

by rules.pcb, qui réside dans le dossier \P-CAD 2001 Trial\Demo\.

2. Dans le menu Utils, choisissez P-CAD InterPlace\PCS pour lancer les outils de
placement interactif de P-CAD.

3. Sélectionnez File » Load PCB Design. Développez votre espace de travail de
manière à visualiser la carte, le Gestionnaire de projet et l'Editeur de contraintes.
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du nom de composant dans l'arborescence des
contraintes. Sélectionnez le Composant T1.
Vous remarquerez que la règle Component
Spacing est initialisée à 30,0mil en fonction
d'une analyse if-then-else mettant en jeu
d'autres contraintes hiérarchiques de projet.

8. Sélectionnez l'option Physical Overlay dans 
la Barre d'outils Visual Placement Area, de
manière à faire apparaître les régions où
vous pouvez placer T1 sans violer ses
contraintes physiques de conception -
autrement dit, l'espacement des composants.

9. Sélectionnez T1 dans l'Affichage de carte et
faites-le glisser vers l'intérieur du tracé de la
carte. Vous remarquerez que P-CAD 2001
affiche les zones de la carte qui respectent les
règles de conception, ce qui vous aide à
déterminer quelles contraintes de conception
limitent les options de placement.

Comment procède-t-on pour enregistrer les modifications apportées
au placement et/ou aux contraintes dans l'environnement de projet ?
1. Une fois que vous avez fini de modifier le placement des composants ou la

définition des règles de conception, sélectionnez l'option File » Update PCB ou 
File » Update Schematic.

2. Toutes vos modifications seront répercutées dans la base de données
correspondantes.

3. Vous avez fini d'utiliser P-CAD InterPlace/PCS. Refermez la fenêtre et retournez au
Circuit imprimé.

9. Tandis que le groupe de composants est encore
sélectionné, cliquez et maintenez le bouton
gauche de la souris enfoncé pour faire glisser le
groupe vers les limites de l'emplacement souhaité.

Comment contrôle-t-on ses contraintes
de conception tout en plaçant ses
composants ?

1. Sous l'éditeur de circuits imprimés de P-CAD 2001, ouvrez le fichier IPLPCS Noise
and Coupling Results.pcb, qui réside dans le dossier \P-CAD 2001 Trial\Demo\.

2. Dans le menu Utils, choisissez P-CAD InterPlace\PCS pour lancer les outils de
placement interactif de P-CAD.

3. Sélectionnez File » Load PCB Design. Développez votre espace de travail de
manière à visualiser la carte, le gestionnaire de projet et l'Editeur de contraintes.

4. Entrez dans le Gestionnaire de projet, onglet Nets. Sélectionnez Nets et cliquez
avec le bouton droit de la souris. Choisissez Show Connections.

5. Entrez dans le Gestionnaire de projet, onglet Components à droite de votre écran.
Sélectionnez Ref Des MTG1 et faites-le glisser à
travers la fenêtre, vers le coin supérieur gauche de
la carte dans l'Affichage de carte.

6.  Multi-sélectionnez les composants J1 et J2 en
maintenant la touche CTRL enfoncée durant la
sélection. Une fois les composants sélectionnés,
relâchez la touche CTRL et faites-les glisser vers le
bord gauche de la carte.

7. Entrez dans l'Editeur de contraintes au bas de
votre écran. Cliquez sur le signe + situé en regard 
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Comment route-t-on une carte manuellement ? 
Le routage manuel est un outil très souple qui vous permet de placer vos traces avec
une grande précision. Pour faciliter votre routage et le rendre plus efficace, vous
pouvez utiliser une grille relative ou non conforme. Pour ce faire, sélectionnez
l'option Options » Grids pour afficher la boîte de dialogue Options Grids.

Etapes du routage manuel :
1. Ouvrez le fichier Demo1_u.pcb, qui réside dans le dossier \P-CAD 2001 Trial\Demo\.

2. Effectuez un zoom de manière à pouvoir facilement sélectionner une ligne de
connexion. Sélectionnez l'option Route » Manual.

3. Activez le DRC en ligne pour le routage, en choisissant Options » Configure,
Online DRC et en sélectionnant la case à cocher Enable Online DRC, ou en
cliquant sur l'icône Online DRC de la Barre d'outils des commandes. Sous Options
» Configure, vous pouvez activer des contrôles de règles de conception en ligne
spécifiques au DRC en ligne. Le DRC en ligne annote et documente les erreurs de
règle de conception provoquées durant le routage de la carte.

4. A l'aide de la touche de raccourci "L", changez la couche en cours à Top. Le
routage doit se faire sur une couche de signal. La couche Top étant une couche de
signal, elle peut être utilisée pour le routage. Sélectionnez Options » Layers pour
déterminer les types de couches devant figurer dans votre projet.

5. A l'aide de la touche de raccourci "G", basculez vers la grille de routage de votre
choix. Ce routage doit être basé sur la connexion choisie.

6. Cliquez directement sur une ligne de connexion à proximité d'une pastille de
début pour la sélectionner en vue du routage. Vous remarquerez à quoi ressemble
un début de trace. Maintenez le bouton de la souris enfoncé et faites glisser le
segment de trace comme vous le souhaitez. Relâchez le bouton à l'emplacement
où vous voulez voir apparaître le premier vertex.

Routage manuel, interactif et automatique
à reconnaissance de formes

Ensuite, cliquez à l'emplacement où vous voulez
voir apparaître le 3ème vertex. Le mode orthogonal
sélectionné vous crée automatiquement le 2nd
vertex. Vous pouvez limiter les modes orthogonaux
actifs en sélectionnant Options » Configure,
Route et en désactivant les modes orthogonaux
que vous ne voulez pas. Pour basculer entre les
modes orthogonaux sélectionnés, appuyez sur la
touche "O" avec le bouton de la souris relâché
pendant le routage. Pour basculer d'un vertex à
l'autre, utilisez la touche de raccourci "F".

7. A l'aide de la touche de raccourci "L", passez à la
couche Bottom pour router les segments dont
les circuits de routage sont bloqués sur la couche
Top. Lorsque vous changez de couche en mode
routage, la traversée en cours ou le style de
traversée spécifié dans les attributs
d'équipotentielles est automatiquement placé
pour connecter les couches entre elles.

8. Pendant la procédure de routage et de
changement de couche, vous pouvez effectuer un
zoom avant (+) ou arrière (-) chaque fois que nécessaire.

9. Pour suspendre le routage, choisissez de traiter le reste de la trace à l'aide
du bouton droit de la souris ou de la touche Echap. Vous pouvez arrêter
le routage sans terminer la trace à l'aide de la touche "barre oblique" (/),
qui vous permet de suspendre le processus. Les touches de raccourci
utilisées pour terminer ou suspendre le routage peuvent être configurées
par l'utilisateur dans la boîte de dialogue Options » Configure, Route.
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9. A l'aide de la touche de raccourci "G", basculez vers la grille de routage de votre
choix. Cette grille doit être basée sur la connexion choisie.

10. Effectuez un zoom avant (+) vers une région du projet. Choisissez une connexion
à router. L'extrémité la plus proche du point où vous avez sélectionné la
connexion devient le point source, tandis que l'autre extrémité devient le point
de destination. Maintenez le bouton de votre souris enfoncé, tout en faisant
glisser la piste vers son emplacement souhaité. Vous remarquez que la zone de
routage visible vous dirige à travers les circuits adéquats ou à travers les régions
qui ne violent pas les contraintes de conception que vous avez configurées. Ces
circuits de routage sont déterminés en examinant les entités du circuit imprimé
et les paramètres que vous avez définis pour l'espacement et la largeur, ainsi que
les zones de keepout que vous avez définies, le cas échéant.

11. L'outil de routage interactif fait courir le cuivre inutilisé ayant la bonne largeur
d'équipotentielle et les espacements conformes aux règles de conception depuis
le point source vers la position du curseur. Vous remarquerez que, tandis que
vous déplacez le curseur, la connexion relie le curseur au second nœud de la
connexion, de manière à indiquer la portion qui reste à router. Lorsque vous
cliquez puis relâchez le bouton de la souris sur un point dont les
coordonnées ne correspondent pas au nœud de destination, les lignes qui
n'étaient pas reliées sont placées sur le circuit imprimé.

13. Après avoir établi une direction de trace et procédé au routage manuel à
travers les régions critiques, sélectionnez le bouton droit de votre souris pour
activer le menu contextuel interactif et sélectionnez l'option Complete pour
activer l'algorithme de routage interactif, de manière à terminer la trace. Si
cette dernière doit manœuvrer à travers une zone congestionnée avant de
terminer, activez l'option Push Traces en la sélectionnant dans le menu
contextuel ou sur la Barre d'outils de routage. Activez cette option avant de
terminer le routage. En effet, elle vous permet d'apporter des segments de
trace ou des traversées supplémentaires dans des régions déjà routées. 

Comment route-t-on une carte de manière interactive ?
1. Ouvrez le fichier Demo1_p.pcb, qui réside dans le dossier \P-CAD 2001

Trial\Demo\.

2. Sélectionnez Options » Configure, onglet Route pour définir vos préférences
de Routage interactif.

3. Sélectionnez la case à cocher Honor Layer Bias pour honorer l'inclinaison de la
couche à l'aide de l'option de menu Options » Layers.

4. Sélectionnez la case à cocher Show Routable Area pour activer la zone de
routage visible contenant les circuits de routage disponibles en tentant compte
des paramètres de routage tels qu'espacement et largeur des traces. Sous
Windows NT et Windows 2000, cette zone apparaît en hachures transparentes ;
sous Windows 95 et 98, elle apparaît en couleur transparente.

5. Sélectionnez Maximize Hugging ou Minimize Length en tant que règle pour les
traces routées de manière interactive. Si vous sélectionnez Maximize Hugging, le
placement des traces maximise l'enveloppement des obstacles. L'option Minimize
Length génère la route la plus droite possible, dénuée de traversées (en

minimisant les coins).
Cette option maximise
l'utilisation des traces à
45°.

6. Sélectionnez OK pour enregistrer les paramètres de votre boîte de dialogue et
retourner à l'Editeur de circuits imprimés.

7. Activez le routage interactif en sélectionnant l'outil Route Interactive dans la
Barre d'outils de routage ou en sélectionnant l'option Route » Interactive.

8. A l'aide de la touche de raccourci "L", changez la couche en cours à Top. Le
routage doit se faire sur une couche de signal. Sélectionnez l'option Options »
Layers pour déterminer les types de couches présents dans votre projet.
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Cette option reroute automatiquement les obstacles de trace, ce qui minimise
l'édition manuelle et vous permet de terminer la connexion rapidement. Si le
fait de pousser les traces ne résout pas le problème de congestion, utilisez le
menu contextuel ou la touche de raccourci "L" pour passer à une nouvelle
couche de routage. Lorsque vous changez de couche pendant le routage, une
traversée est automatiquement placée dans votre projet. Le style de la traversée
placée correspond au style Current que vous avez choisi dans Options » Via
Style ou à celui que vous avez attribué à l'équipotentielle dans Options »
Design Rule, onglet Net. Hormis pousser les traces et de changer de couche, le
menu contextuel vous permet également de modifier le style de la traversée en
cours, de suspendre la trace, d'snnuler le routage, de modifier les paramètres de
configuration du routage interactif et de dérouler les segments de trace.

14. Poursuivez ainsi jusqu'à ce que votre travail soit 
entièrement terminé.

Le routage interactif allie contrôle du placement des
traces et intelligence des règles de conception dans ses
nombreux outils et fonctionnalités. La possibilité de
pousser les traces, l'enveloppement maximal, l'affichage
de la région de routage et les routes de longueur
minimales, ainsi que le routage de bus, le routage multi-
fils et le fan-out automatique permettent à P-CAD 2001
d'optimiser le routage des projets les plus complexes.

Comment route-t-on automatiquement tout ou
partie d'un circuit imprimé ?
1. Ouvrez le fichier Demo1_u.pcb, qui réside dans le

dossier \P-CAD 2001 Trial\Demo\.

2. Sélectionnez l'option View » Extent pour afficher l'ensemble des objets
placés dans l'espace de travail.

3. Pour router automatiquement une équipotentielle donnée, sélectionnez
l'option Route » AutoRouters.
Choisissez l'option P-CAD Shape
Route du menu déroulant
AutoRouter et sélectionnez Start.

4. Le projet ouvre l'interface de routage
automatique. Sélectionnez l'option
Tools » AutoRoute Net. Le curseur
prend la forme d'une flèche.
Sélectionnez n'importe quelle pastille
sur l'équipotentielle concernée ou
n'importe quelle ligne de connexion.
Le routeur automatique à
reconnaissance de formes de P-CAD
route automatiquement l'intégralité de
l'équipotentielle. Continuez en
sélectionnant d'autres équipotentielles à router ou cliquez sur le bouton
droit de la souris ou appuyez sur la touche Echap pour quitter le mode de
routage automatique des équipotentielles.

5. Le routeur automatique à reconnaissance de formes de P-CAD vous permet
de router automatiquement une connexion d'une équipotentielle, toutes les
pastilles d'un composant ou toutes les connexions d'une région. Pour cela, il
vous suffit de répéter la procédure décrite ci-dessus et de sélectionner
l'option Autoroute correspondante du menu Tools.

6. Pour router automatiquement l'intégralité de votre circuit imprimé,
sélectionnez l'option Tools » Start AutoRouter du menu Shape Based 
Auto Router.
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7. Une fois le routage terminé, sélectionnez l'option File » Save et l'option
Return pour enregistrer votre routage et retourner à l'éditeur de circuits
imprimés.

Le routeur automatique de P-CAD 2001 allie des algorithmes évolués de routage
à une architecture polygonale à reconnaissance de formes extrêmement
puissante, ce qui lui permet de réaliser un routage automatique rapide et de
qualité avec un taux de réussite très élevé et garantit des résultats
professionnels, quelle que soit la technologie de packaging des composants.

Analyse évoluée de l'intégrité du signal

Le Simulateur d'intégrité du signal de P-CAD 2001,
livré avec chaque licence de suite complète, est intégré
de manière transparente avec l'éditeur de circuits
imprimés pour minimiser les modifications futures et
résoudre vos problèmes de rapidité et d'EMC/EMI
avant que votre carte ne soit envoyée en fabrication.

A mesure que les circuits imprimés se complexifient,
avec des fréquences d'horloge élevées, des vitesses de
commutation de dispositifs plus élevées et une densité
plus importante, le besoin d'analyser l'intégrité du
signal avant la fabrication se fait plus pressant. Les
délais de propagation, les impédances d'équipotentielles, les réflexions de signal et
le crosstalk ne relèvent plus du seul domaine du spécialiste de conception haute
fréquence. Les problèmes d'intégrité du signal peuvent affecter n'importe quelle
projet. Les constructeurs produisent des composants toujours plus petits et plus
rapides avec des vitesses de plus en plus élevées et les familles à logique lente
disparaissent des catalogues. Il devient de plus en plus nécessaire pour chaque
concepteur de penser à l'intégrité du signal pendant le tracé et le routage des
circuits imprimés.

Comment importe-t-on des équipotentielles de circuit imprimé
dans l'intégrité du signal P-CAD en vue de les analyser ?
1. Ouvrez le fichier Demo.pcb, qui réside dans le dossier \P-CAD 2001

Trial\Demo\Signal Integrity.

2. Lancez P-CAD Signal Integrity en sélectionnant l'option Utils » P-CAD Signal
Integrity. L'interface de l'application Signal Integrity s'affiche.

3. Pour importer les équipotentielles du circuit imprimé, sélectionnez l'option File
» Get Nets. La liste de toutes les équipotentielles et classes d'équipotentielles
figurant dans le projet en cours s'affiche.
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Comment spécifie-t-on la pile de couches du circuit imprimé en vue 
de l'analyse d'intégrité du signal ?
1. Ouvrez le fichier Demo.pcb, qui réside dans le dossier \P-CAD 2001 Trial\Demo

\Signal Integrity.

2. Lancez P-CAD Signal Integrity en sélectionnant l'option Utils » P-CAD Signal 
Integrity. L'interface de l'application Signal Integrity s'affiche.

3. Importez les équipotentielles de votre circuit 
imprimé en sélectionnant l'option File » Get 

Nets. La liste de toutes les équipotentielles et 
classes d'équipotentielles figurant dans le 
projet en cours s'affiche.

4.Sélectionnez l'option Edit » Layer Stack
pour afficher la boîte de dialogue Layer Stack.

5.Sélectionnez une couche et saisissez les 
modifications que vous souhaitez apporter 
à Diéléctric Type ,Height, et EpsR.

Vous pouvez également modifier la l'epaisseur
du et l'ordre des couches dans cette boîte 
de dialogue. 

Comment doit-on effectuer un filtrage des équipotentielles en vue
d'identifier les équipotentielles critiques ?
1. Ouvrez le fichier Demo.pcb, qui réside dans le dossier \P-CAD 2001

Trial\Demo\Signal Integrity.

2. Lancez P-CAD Signal Integrity en choisissant l'option Utils » P-CAD Signal
Integrity. L'interface de l'application Signal Integrity s'affiche.

3. Pour importer les équipotentielles du circuit imprimé, sélectionnez l'option File
» Get Nets. La liste de toutes les équipotentielles et classes d'équipotentielles 
figurant dans le projet en cours s'affiche.

4. Sélectionnez l'option Edit » Nets pour afficher la boîte de dialogue Edit Nets.

5. Dans cette boîte de dialogue, vérifiez que la catégorie
et les tensions sont correctes pour chacune des
équipotentielles figurant dans le projet actif.
Sélectionnez les équipotentielles VCC, VCC1, VCC2 et
VCC3 en appuyant sur la touche Ctrl et en
sélectionnant chacun des noms d'équipotentielle.
Changez la catégorie d'équipotentielle en Supply et la
valeur en 5.00 V. Sélectionnez Apply pour modifier les
valeurs des équipotentielles.

6. Sélectionnez l'option To Database pour sauvegarder
ces modifications dans la base de données demo.pcb
en tant qu'attributs d'équipotentielles spécifiques.

7. Sélectionnez OK pour retourner à l'interface de
l'application Signal Integrity. Dans la zone de liste des
équipotentielles, multi-sélectionnez les équipotentielles
DEMO_D0 à DEMO_D20. Pour procéder à une
sélection multiple, choisissez l'équipotentielle
DEMO_D0, appuyez sur la touche MAJ et maintenez-la
enfoncée et choisissez l'équipotentielle DEMO_D20. 
Les équipotentielles souhaitées apparaissent en
surbrillance dans la base de données demo.pcb en tant
qu'attributs d'équipotentielles spécifiques.

8. Sélectionnez l'option Edit » Take Over. Les éléments de l'équipotentielle
apparaissent dans la fenêtre P-CAD Signal Integrity.

9. Sélectionnez l'option Simulation » Screening pour afficher la boîte de dialogue
Signal Integrity Screening de P-CAD.

10.Dans la boîte de dialogue Screening, sélectionnez l'option View » Arrange Nets
by » Maximum Overshoot (Rising Edge). Vous pouvez à présent facilement
identifier les équipotentielles critiques pouvant nécessiter une analyse.
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Le filtrage permet une simulation rapide de toutes les équipotentielles de votre projet,
de manière à fournir des informations géométriques et
des valeurs estimatives des effets sur l'intégrité du signal.

Comment procède-t-on à une simulation de
réflexion ?

1. Ouvrez le fichier Demo.pcb, qui réside dans le dossier
\P-CAD 2001 Trial\Demo\Signal Integrity.

2. Lancez P-CAD Signal Integrity en sélectionnant l'option
Utils » P-CAD Signal Integrity. L'interface de
l'application Signal Integrity s'affiche.

3. Pour importer les équipotentielles du circuit imprimé,
sélectionnez l'option File » Get Nets. La liste de
toutes les équipotentielles et classes d'équipotentielles
figurant dans le projet en cours s'affiche.

4. Sélectionnez l'équipotentielle Demo_A31 et choisissez
Edition » Reprendre.

5. Sélectionnez l'option Simulation » Reflection pour
afficher l'analyseur des ondes d'intégrité du signal.

6. Ayant identifié cette équipotentielle comme étant problématique, nous pouvons
utiliser le Conseiller de terminaison pour vous aider à réduire la surtension. Choisissez
l'option File » Exit pour retourner à l'interface de l'application Signal Integrity.
Sélectionnez Demo_A31 nœud U9 broche 9 dans la fenêtre Simulation.

7. Sélectionnez l'option Simulation » Termination Advisor. Dans la boîte de dialogue
Termination Advisor, choisissez Parallel R to GND. Initialisez la résistance de R2
à 100,0 Ohm.

8. Sélectionnez OK dans le Conseiller de
terminaison pour retourner à l'interface de
l'application Intégrité du signal.Sélectionnez
l'option Simulation » Reflection pour
afficher l'analyseur d'ondes d'intégrité du
signal et contrôler la surtension de U9-9 suite
à l'ajout de résistance.

9. L'introduction de la résistance ayant résolu le
problème du bruit de sonnerie, nous allons
enregistrer notre solution dans le circuit
imprimé. Sélectionnez l'option File » Exit
dans l'analyseur d'ondes pour retourner à l'interface
de l'application Signal Integrity.

10.Sélectionnez l'option Simulation » Termination
Advisor. Dans la boîte de dialogue Termination
Advisor, sélectionnez l'option Send to P-CAD PCB.
Un Info Point est inséré dans le circuit imprimé, à
l'emplacement où vous devez ajouter une résistance.

11.Pour trouver l'info-point, retournez au projet de
circuit imprimé. Sélectionnez l'option Utils » Find
Errors. Une erreur Termination Network s'affiche. Sélectionnez
l'option Jump de la boîte de dialogue Find Errors pour accéder à
l'emplacement de l'info-point.

Comment procède-t-on à une simulation Crosstalk ?
Le simulateur Crosstalk de P-CAD simule le couplage entre les traces
et les segments parallèles adjacents.

1. Ouvrez le fichier Demo.pcb, qui réside dans le dossier \P-CAD 2001
Trial\Demo\Signal Integrity.
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Gestion intégrée des bibliothèques de
composants sous P-CAD 2001

Pour assurer la réussite d'un projet de conception, il est essentiel de pouvoir
en retrouver, créer et gérer les composants. P-CAD 2001 repousse les limites
de l'organisation des bibliothèques grâce à son gestionnaire de bibliothèques
qui fait office de véritable centre de contrôle des bibliothèques.

Où se trouvent les bibliothèques intégrées de P-CAD 2001 ?
P-CAD 2001 est livré avec un jeu complet de bibliothèques intégrées. Ces
bibliothèques résident dans le dossier \P-CAD 2001\Lib. En outre, le P-CAD
Library Development Center (PLDC) développe régulièrement de nouvelles
bibliothèques de composants en conformité avec un système qualité certifié ISO
9001. Ces bibliothèques peuvent être obtenues gratuitement et téléchargées
depuis le site Web de P-CAD, www.pcad.com. 
Ces composants intégrés complets et de qualité
garantie sont définis avec toutes les données
symboliques, physiques et électriques requises.

Comment configure-t-on les
bibliothèques P-CAD en vue de les
utiliser dans l'environnement de projet ?
Pour utiliser les composants intégrés contenus
dans l'une des bibliothèques de P-CAD 2001 dans
un schéma ou un projet de circuit imprimé, vous
devez d'abord configurer la bibliothèque dans
l'environnement du projet.

1. Partez de n'importe quel projet de schéma ou de circuits imprimé. 
Sélectionnez Bibliothèque » Configuration.

2. Cliquez sur le bouton Add de la boîte de dialogue Library Setup pour 

2. Lancez P-CAD Signal Integrity en sélectionnant
l'option Utils » P-CAD Signal Integrity.
L'interface de l'application Signal Integrity
s'affiche.

3. Pour importer les équipotentielles du circuit
imprimé, sélectionnez l'option File » Get
Nets. La liste de toutes les équipotentielles et
classes d'équipotentielles figurant dans le
projet en cours s'affiche.

4.  Sélectionnez l'option Options » Configurer et tapez
1 mm dans les champs Maximum Couple Distance
et Minimum Couple Length. Cette boîte de
dialogue définit les
paramètres
géométriques de la
recherche automatique
de traces parallèles.

5. Cliquez sur OK pour
retourner à l'interface

de l'application Intégrité du signal. Choisissez
l'équipotentielle DEMO_D1 et sélectionnez l'option
Edition » Find Coupled Nets. Les équipotentielles
DEMO_D1, DEMO_D0, et DEMO_D2 doivent apparaître en surbrillance.
Sélectionnez l'option Edit » Take Over.

6. Sélectionnez l'équipotentielle DEMO_D1 dans la fenêtre Simulation, puis
sélectionnez l'option Simulation » Set Victim Net.

7. Sélectionnez l'option Simulation » Crosstalk. L'analyseur d'ondes doit s'afficher
avec le résultat de la simulation de reflections de signaux.
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ouvrir la boîte de dialogue Library File Listing. Parcourez votre système 
Windows jusqu'à trouver le fichier de bibliothèque recherché (*.lib). Les 
bibliothèques intégrées livrées avec la version d'évaluation de P-CAD 2001 
résident dans le dossier \P-CAD 2001\Lib.

3. Sélectionnez la bibliothèque souhaitée et cliquez sur Open. Pour sélectionner 
plusieurs bibliothèques, appuyez sur la touche Ctrl tout en sélectionnant chacune 
des bibliothèques souhaitées. Si vous choisissez l'option Open, la liste des 
bibliothèques que vous avez sélectionnées apparaît dans votre boîte de dialogue 
Library Setup. Sélectionnez OK pour fermer la boîte de dialogue. Les 
bibliothèques sélectionnées sont à présent chargées dans l'éditeur de schémas ou
l'éditeur de circuits imprimés et vous pouvez ajouter 
les composants qu'elles contiennent à votre projet.

Comment procède-t-on pour rechercher puis
placer le symbole de schéma d'une capacité
polarisée ?
1. A partir de l'environnement de schéma, configurez les

bibliothèques Demo.lib et Modfax0.lib en suivant la
procédure indiquée ci-dessus. Ces bibliothèques
résident dans le dossier \P-CAD 2001 Trial\Demo.

2. Sélectionnez l'option Placer » Pièce du menu de schéma ou de la barre d'outils
Placement.

3. Sélectionnez l'option Query de la boîte de dialogue Place Part.

4. La boîte de dialogue Query s'ouvre. Pour interroger les deux bibliothèques,
sélectionnez Demo.lib et Modfax0.lib sous l'en-tête Open Libraries dans la
boîte de dialogue.

5. Sélectionnez Criteria (And) pour le champ Component Name et sélectionnez
l'opérande d'interrogation IsLike dans le menu déroulant. Ensuite, sélectionnez

la cellule et saisissez Cap*, pour voir apparaître "IsLike Cap*". Ensuite, sélectionnez
Criteria (And) pour le champ Number of Pins et sélectionnez l'opérande = .
Type 2 dans le menu déroulant pour voir apparaître "=2" dans la cellule.

L'interrogation permet les comparaisons logiques (<,>,=) et les opérations booléennes
(AND, OR) sur les attributs des composants et les valeurs des propriétés. Elle permet
également d'utiliser le "*" en tant que caractère générique multiple et le "?" en tant
que caractère générique unique.

6. Cliquez sur Query pour retrouver les composants qui correspondent aux critères
de recherche.

7. Une boîte de dialogue Viewer apparaît. Elle
contient les propriétés et les attributs des
composants correspondants. Déroulez 
l'écran vers la droite pour rechercher 
l'attribut Description.

8. Cliquez sur Axial Polarized Capacitor pour
sélectionner ce composant en vue de le placer.

9. Sélectionnez Place pour fermer l'afficheur et
ouvrir immédiatement la boîte de dialogue
Place Part pour placer le composant
sélectionné.

10. Etant donné que le composant souhaité,
CAP100AP, est présélectionné, il vous suffit
de cliquer sur OK pour placer la
capacitance souhaitée dans votre projet. 
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Comment crée-t-on un nouveau modèle de circuit imprimé à
l'aide de l'Assistant Modèle ?

1. Ouvrez l'éditeur de modèles P-CAD Pattern Editor à partir du menu Utils
de l'éditeur de schémas ou de circuits imprimés ou du menu Programs » P-

CAD 2001, ou en lançant pated.exe.

2. Une fois que vous avez lancé l'éditeur
de modèles, sélectionnez Pattern »
Pattern Wizard pour ouvrir
l'Assistant Modèle. Il s'agit d'un
assistant graphique qui vous aide à
créer vos modèles.

3. Spécifiez ARRAY dans Pattern Type,
11 en tant que nombre de pastilles
vers le bas et nombre de pastilles en
travers, 100,0mil en tant
qu'espacement entre pastilles et 3
pastilles de cutout vers le bas et en
travers. Choisissez (Default) en tant
que style des pastilles. Contrôlez les

pastilles des coins comme vous le souhaitez.

4. Activez l'option Silk Screen. Configurez les paramètres de sérigraphie comme
suit : largeur des lignes de 10,0mil, largeur des rectangles de 1200,0mil,
hauteur des rectangles de 1200,0mil et type d'encoche Upper Left.

5. Configurez la numérotation des broches de la table en cliquant sur le bouton
Default Pin Designators. Entrez dans l'assistant Default Pin Designator
Assistant et choisissez un numéro de ligne de début (Row Value) de A et
un numéro de colonne de début (Column Value) de 1.

Sélectionnez la case située en haut à gauche pour qu'elle 
serve de point de départ de la numérotation. Une fois 
sélectionné, le graphique situé à droite doit être mis à jour
dynamiquement en fonction du nouveau système de 
numérotation. Saisissez les caractères I,O pour qu'ils soient
omis dans la numérotation de la table. Confirmez la 
numérotation des désignateurs de broches et cliquez sur 
OK pour retourner à l'Assistant Modèle.

6. Confirmez la forme et la configuration du modèle et 
appuyez sur Finish pour placer le modèle que vous venez 
de créer dans l'éditeur.

7. Ajoutez les attributs que vous avez définis en choisissant 
Pattern » Attributes, si vous le souhaitez.

8. Choisissez Pattern » Save pour enregistrer l'objet en tant 
que modèle dans une bibliothèque sélectionnée. Sinon, 
choisissez Pattern » File Save As pour enregistrer le projet
en tant que fichier de base de données de modèle (*.pat)
à éditer ultérieurement

P-CAD 2001 comporte des assistants graphiques pour les
symboles et les modèles. Ces assistants, alliés aux outils
d'édition des symboles et des modèles, ainsi qu'à la
possibilité d'effectuer des liaisons croisées et de contrôler les
données par rapport aux définitions de composants,
permettent de modifier, de créer et de gérer les données des
composants avec P-CAD 2001 rapidement, efficacement et,
surtout, avec exactitude.
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Comment génère-t-on une sortie de fabrication ?
1. Ouvrez le fichier Tutor3.pcb, qui réside dans le dossier \P-CAD 2001

Trial\Tutorial\.

2. Dans la boîte de dialogue File » Export » Gerber, cliquez sur l'option
Setup Output Files pour afficher la boîte de dialogue Setup Output Files.

3. Tapez TOP dans la zone d'édition File Extension. Les fichiers de sortie
ont le même nom de base que le fichier du projet, mais leur extension
est unique. Généralement, les extensions utilisées pour différencier les
fichiers sont propres à la couche, comme par exemple TOP pour la
couche Top, BOT pour la couche Bottom, TSK pour Top Silk, etc.

4. Mettez en surbrillance la couche Top dans la zone de liste
Layers. Activez Pads and Vias. Sélectionnez la case à
cocher View log file upon completion pour rendre
compte des erreurs détectées pendant la génération des
fichiers Gerber. Cliquez ensuite sur Add pour ajouter le
fichier Tutor3.TOP à la liste des fichiers de sortie.

5. Tapez BOT dans la zone d'édition File Extension.
Sélectionnez la couche Bottom dans la zone de liste Layers
et désélectionnez les autres couches, le cas échéant. Utilisez
les mêmes options et le même chemin de sortie que pour
la couche TOP. Cliquez sur Add pour ajouter le fichier
Tutor3.BOT à la liste des fichiers de sortie.

6. Tapez TSK dans la zone d'édition File Extension. Mettez
en surbrillance la couche Top Silk dans la zone de liste Layers, ce qui vous désactive
toutes les autres couches. Activez Ref Des, Type et Value, ce qui vous désactive tous
les autres éléments. Cliquez sur Add pour ajouter le fichier Tutor3.TSK à la liste des
fichiers de sortie.

7. Spécifiez l'Output Path (Chemin de sortie). Si vous indiquez un chemin invalide, un
message d'erreur s'affiche lorsque vous tentez de fermer la boîte de dialogue.

Sortie d'un projet complet et support à la fabrication

8. Cliquez sur Close pour quitter la boîte de dialogue et retourner à la boîte
de dialogue principale File Gerber Out. Les fichiers Gerber Tutor3.TOP,
Tutor3.BOT et Tutor3.TSK apparaissent dans la zone de liste Output Files.

9. Dans la boîte de dialogue File Gerber Out, cliquez sur Apertures pour
afficher la boîte de dialogue Aperture Assignments. A partir de là, vous
pouvez créer et affecter vos ouvertures automatiquement ou manuellement.
Cliquez sur Auto pour affecter l'ouverture automatiquement et sélectionnez
Close pour enregistrer vos paramètres et retourner à la boîte de dialogue
File Gerber Out.

10. Dans la boîte de dialogue File Gerber Out, cliquez sur Drill Symbols pour
afficher la boîte de dialogue Drill Symbol Assignments. Cette boîte de
dialogue vous permet d'affecter vos
symboles de perçage manuellement ou
automatiquement. Cliquez sur Auto
pour une affectation automatique.
Sélectionnez Close pour sauvegarder 
vos modifications.

11. Sélectionnez Gerber Format dans la
boîte de dialogue File Gerber Out pour
configurer vos unités de sortie, votre type
numérique et votre format. Par défaut, 
le format de sortie est initialisé à 274-D.
Sélectionnez Close pour sauvegarder 
vos modifications.

12. Choisissez Set All pour mettre en surbrillance tous les fichiers Gerber
configurés dans votre Output Path. Si vous le souhaitez, sélectionnez Self-
Extracting (.EXE) ou Compressed (.ZIP) pour comprimer les fichiers de sortie
sous l'un des formats de fichier ou sélectionnez l'option Load in Camtastic.

13. Cliquez sur le bouton Generate Output Files dans la boîte de dialogue File
Gerber Out pour générer vos fichiers de fabrication Gerber.
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Comment génère-t-on un fichier de sortie DXF ?
1.  Sélectionnez l'option File » Export » DXF de la barre d'outils pour

ouvrir la boîte de dialogue.

2. Cliquez sur le bouton DXF Filename. La boîte de dialogue File 
Save s'affiche. Vous pouvez y sélectionner un fichier ou saisir un 
nom de fichier.

3. Tapez le nom du fichier DXF que vous souhaitez enregistrer dans la
zone File Name.

4. Cliquez sur Save.

5. Sélectionnez les couches du circuit imprimé à sortir dans la zone 
de liste Layers. Chaque couche du circuit imprimé est émise vers 
une couche DXF différente. Les boutons Set All et Clear All
permettent de sélectionner ou d'effacer toutes les couches de la 
carte en une seule opération.

6. Si vous choisissez d'émettre les Drill Symbols, spécifiez la taille des symboles 
résultants. Vous devez également sélectionner les types de trous que vous souhaitez 
exporter. Vous pouvez choisir Plated Holes, Non-plated Holes ou All Holes. Pour 
effectuer ou examiner les affectations de symboles de perçage, cliquez sur le bouton 
Setup pour ouvrir la boîte de dialogue Drill Symbol Assignments.

7. Choisissez l'unité de sortie souhaitée, Inch, Cm ou Mm en cliquant sur le bouton radio 
correspondant dans la zone DXF Units.

8. Si vous ne souhaitez émettre que certains objets, sélectionnez-les dans le projet avant 
de sélectionner l'option File » DXF Out, puis activez l'option Selected Objects.

9. Cliquez sur la zone Draft pour émettre en mode brouillon. Le mode Draft produit des 
fichiers plus petits et plus rapides à traiter. Néanmoins, les dessins produits dans ce mode 
ne sont pas exacts car les lignes n'ont pas de largeur et les zones ne sont pas remplies.

10. Sélectionnez la case à cocher Component Height pour émettre la hauteur des 
composants en fonction de leur attribut Component Height.

11. Supprimez l'émission du cuivre des trous de montage en cochant la case No Mt
Hole Cu.

12. Sélectionnez la case à cocher Include Title Sheet pour émettre des pages de titre.

13. Sélectionnez la case à cocher Include True Type Fonts pour émettre le texte
en police True Type. Le fait de désélectionner cette case permet d'exporter un
fichier DXF compatible DXF Révision 9.

14. Cliquez sur OK pour générer le fichier de sortie DXF.
Vous pouvez annuler l'opération en appuyant sur
Echap ou en cliquant sur le bouton droit de la souris.

La commande DXF Out permet de créer des fichiers DXF à
partir de vos conceptions de circuit imprimé. Ces fichiers
peuvent être transférés vers AutoCAD® (version 9.0 et
supérieure) et d'autres progiciels de CAO mécanique.

Comment crée-t-on une table de perçage ? 

1. Ouvrez le fichier Tutor3.pcb, qui réside dans le dossier
\P-CAD 2001 Trial \Tutorial\.

2. Sélectionnez File » Gerber Out, cliquez sur Drill
Symbols pour affecter des symboles de perçage à vos
diamètres de trous. Dans la boîte de dialogue Drill
Symbol Assignments, affectez les symboles de perçage
en cliquant sur le bouton Auto. Ceci permet d'affecter
automatiquement les symboles de perçage. Sélectionnez
Close pour sauvegarder vos modifications et fermer la
boîte de dialogue Fichier Gerber Out.

3. Pour créer une table de perçage à l'aide des outils
évolués de documentation de projet de P-CAD, sélectionnez DocTool » Place
Table et cliquez une fois dans l'espace de travail. La boîte de dialogue Place
Table s'affiche.
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de votre conception et en améliorer la gestion. La table de perçage met en
correspondance les symboles de perçage affichés sur le projet de circuit imprimé
avec leurs caractéristiques physiques. La table de perçage contient les informations
suivantes : le diamètre du trou, le symbole qui permet d'identifier le trou de
perçage, le nombre de trous ayant un diamètre donné dans le projet et si le trou
est plaqué ou non. Les données contenues dans la table de perçage ou dans les
tables du circuit imprimé peuvent être mises à jour automatiquement par mise en
œuvre des fonctions Update du menu DocTool.

Comment place-t-on un diagramme de
pile de couches dans la base de données
du projet de circuit imprimé ?

1. Ouvrez le fichier Digdemo.pcb, qui réside dans 
le dossier \P-CAD 2001 Trial\Demo\.

2. Utilisez la touche de raccourci "L" pour
naviguer vers la couche Info, qui n'est pas une
couche de signal.

3. Dans le menu PCB, sélectionnez l'option DocTool » Place
Diagram, puis cliquez une fois dans l'espace de travail pour
ouvrir la boîte de dialogue Place Diagram.

4. Changez le titre de "Layer StackUp" en "Layer Configuration".

5. Sélectionnez le style de diagramme Diagram Style #2.

6. Réglez la largeur de ligne Line Width sur 20,0.

7. Cliquez sur OK pour quitter la boîte de dialogue et entrer dans la carte pour
placer le diagramme d'empilement des couches.

8. Placez votre curseur à l'endroit où vous souhaitez placer votre diagramme,
cliquez une fois dans l'espace de travail et relâchez.

Le diagramme d'empilement des couches est inclus dans la sortie de fabrication
Gerber, ainsi que dans les copies papier et dans les fichiers DXF.

4. Dans la liste Table Type, sélectionnez Drill Table en tant que type de table à placer.

5. Spécifiez la largueur de ligne Line Width pour définir l'épaisseur du bord des cellules
de la table.

6. Saisissez un nom de table dans Table Name. Ce nom apparaît centré au-dessus de la
table placée.

7. Sélectionnez un Style de texte pour le contenu de la 
table. Pour modifier un style de texte, cliquez sur le 
bouton Styles de texte pour entrer dans la boîte de 
dialogue Options Styles de texte.

8. Cliquez sur le bouton Advanced » pour personnaliser 
la table de perçage. La boîte de dialogue comporte 
alors également un affichage de la table de perçage 
courante.

9. Dans Hole Dia Units, choisissez les unités de diamètre des
trous dans la table de perçage : pouces ou millimètres.

10.Si vous le souhaitez, vous pouvez ajouter une colonne 
définie par vous à cette boîte de dialogue.

11.Cliquez sur OK pour enregistrer les paramètres de la 
boîte de dialogue et retourner à l'espace de travail du 
circuit imprimé pour placer la table.

12.Utilisez la touche de raccourci "L" pour naviguer vers 
la couche qui n'est pas une couche de signal, Board. 
Cliquez à l'endroit où vous souhaitez placer votre 
table. Si vous maintenez le bouton de la souris 
enfoncé, un contour grisé de la table s'affiche. Faites-le 
glisser pour localiser la table avec plus de précision.

La table de perçage n'est que l'une des nombreuses tables que vous pouvez placer dans
la base de données de votre circuit imprimé pour compléter la documentation


